Issue with shadow

Hello All,

I am getting issue with the shadows here i am using custom buffer geometry with MeshStandardMaterial.
Here when i am enabling the receiveshadow means

mesh.receiveShadow = true

Than i am getting blurry black shades on my plates even there is no objects near to itshadow

Here if we see the plates so they have proper shadows on the ground but there as shadows on themselve too that i dont want because no object is new to them. Also if the objects are near i want the shadow like i have on the ground on this plate
Please can anyone tell me the reason and even my other objects (plates are not receiving shadows properly)


That black effect i remove now i added the emmensive property

Just a wild guess, but maybe try increasing the shadowmap size?

Some options that might help

renderer.setSize(width, height)
renderer.shadowMap.type = THREE.PCFSoftShadowMap

light.shadow.mapSize.width = 4096
light.shadow.mapSize.height = 4096

@Fluqz and @Bossie thank you so much for the valuable solution. Fluqz yes i already tried these setting an it help me in getting the proper shadows but that black effect on the table goes away when i applied the emmensive property on the material.

At an certain position of light my shadows are faded not sharp. I want them to be sharp
Please see the image

My shadow camera settings are left = -0.8, right = 0.8 top=0.8 bottom=-0.8

Near and far parameter are 0.001, 1000

map size is 2048*20


What should be the recoomended ratio in setPixel method suggested above

Dont know how to sharpen shadows. There are different light types. You should check them out in the docs and play with them.

mapSize 2048*20 is quite a lot, maybe tweak here a bit as well

The ratio is calculated by dividing width and height
let ratio = width / height;