FBX Loder Issues

I recently got into three js and have been experimenting with creating a world and some some character movement stuff. The problem is that when I try to animate my 3d character, nothing happens. The model loads in T-pose, but doesn’t seem to have access to it’s other animations. Each animation is saved as an individual fbx file. I tried peering into the console and all I got were these errors:

  1. FBXLoader: Image type “fbm” is not supported.
  2. FBXLoader.js:3312 THREE.FBXLoader: FBX binary version: 7700
  3. GET 404 (Not Found)

I’m running the js on a local live server using VS code’s liveserver addon.

Here’s my import FBXLoader line:

import { FBXLoader } from 'https://cdn.jsdelivr.net/npm/three@0.118.1/examples/jsm/loaders/FBXLoader.js';

And this is my animation function for the 3d model:

LoadAnima() {
        const loader = new FBXLoader();
        loader.load('Emi.fbx', (fbx) => {
            fbx.traverse(c => {
                c.castShadow = true;

            const anim = new FBXLoader();
            anim.load('Idle.fbx', (anim) => {
                this.mixer = new THREE.AnimationMixer(fbx);
                const idle = this.mixer.clipAction(anim.animations[0]);

This is my first time posting on this site, so I don’t really know how this is going to turn out, but any help is appreciated

What is Emi.fbm? Is this supposed to be a special FBX file format?

I’m pretty sure the .fbm is just the output directory of associated textures, it’s simply a directory but for some reason fbx output names the folder with a .fbm extension…

@FL888 I think what you can do is create a textures folder in the same location as your fbx, drop your textures into it and change the paths to the textures in your editor to this directory instead of the .fbm directory

1 Like

Emi.fbx is the 3d model file that I wish to load but I have no idea where the fbm extension came from; it’s written nowhere in my code

Thanks for the reply. I imbedded the textures into the model so I’m not sure how to go about it, but I’ll try making a new folder and setting the path to it and see if that solves anything