Bones animation error with GLTF

Hi folks,

I have some problem with a GLTF model exported with Blender 2.8.
Bones don’t animate correctly in the the online viewer, but it seems that it is correctly exported, since there is no problem when I import the exported model into Blender again.

This is the model :
hero3.glb (108.1 KB)

This is how it looks in the viewer :

Notice that the skinning looks OK, it’s the bone that is wrong.
It looks like some bones are flipped on the Y direction…

This is how it looks in Blender :

When using the three.js based glTF-viewer, I get initially good results.

However, the animation seems broken.

I’ve also tested your model with Babylon.js and Sketchfab but no one produces good results.

So right now, it seems there is something wrong with the glTF importer/exporter.

1 Like

Are you exporting with the “Sample All Animations” option. For my project, the animations are broken unless that is checked.

It increases the file size though which is unfortunate.

There is a bug filed here:

Really hope this gets fixed soon as I am about to sink thousands of dollars into new models/animations…

1 Like



Thank you all for your replies.

As @titansoftime pointed out, it was solved by checking the option for sampling all animation, whose name is now “Always Sample Animations”.

In my case, the file size went from 84kb to 438kb… ( without draco compression for both )
But still, I think this option should be checked by default, since apparently it’s a common issue.

1 Like