Shadow doesn't work

I tried to cast shadow on these objects
Screen Shot 2023-04-10 at 5.46.25 PM
Screen Shot 2023-04-10 at 5.47.41 PM
I used these line of code, but it still doesn’t seem to be working

  1. Did you set up the shadows also in the renderer? (docs)
  2. Is the frustum of the light camera covering the objects you’d like to see casting shadows?
  3. Consider using .traverse instead of .forEach - otherwise there’s a chance you’re not setting shadow casting on all submeshes within the RootNode mesh.
1 Like

It work but it’s giving me a hard time

I don’t know how to fix those black tiles

I did it, thank you

For the future reference - you can skip most of that trouble by just adding three-csm.

Sorry, totally unrelated to the shadow issue, but can you tell me if you used a component library or css framework for the interface of your editor? It looks great!

Thx. I create it with javascript so i don’t have to get the elements from the html file and i used css to style it

I created this class and then I extend it as I create others.