renderer.shadowMap.enabled = true gives weird result

I’m trying to get the result like the image shown below but when shadowMap is set to true, it gives weird effects on texture don’t know. If the shadowMap is set to false then the gltf model doesn’t show shadow at all even if receiveShadow and castShadow of child mesh is set to true. Please help me with this.

sandbox link for the code

What you see are self-shadowing artifacts. One possible solution is to set LightShadow.shadow.bias to a value like -0.001. Doing this for the point lights will look like so:

Thank you for the solution @Mugen87 :v:. It’s really helpful, now I just need to tweak some light settings.