Reasons why scale wouldn't work?

I feel like this is going to be just something dumb I’m doing and I hate even ask, but I’ve spent too much time on this and there’s no shame in asking the experts for help, right? :slight_smile:

I hope it’s ok to just link to my question on StackOverflow. I can copy/paste/format it here if that’s better, just let me know.

The basics, though:
I’m using jcastro76’s fork of peterqliu’s threebox but barring a bug in one of those, it still seems like a core THREE thing. I’ve tried every method of scaling a 3D model (after loading) that I’ve seen mentioned or found by doing a console.dir() dump of the object to see what was available and none of them change the size of the 3D model.
[three.js - Mapbox/threebox Changing Scale On Existing 3D Object Not Working - Stack Overflow](https://)

I see notes about scaling being a multiplication of the size of the object so 1.0 would be “same as the existing size”. So I tried 10 and 100 for all three values of with defaultModel.scale.set(x, y, z) and still nothing.

I know it’s something stupid… please enlighten me on my stupidity. Thanks in advance!


its hard to know without providing some code.
maybe you are scaling the wrong object
see this example for a different perspective
Object3D Hierarchy - Three.js Tutorials (
use the scale sliders, they are only affecting the X dimension

edit.: I just noticed that your stack overflow question has a lot more info to go by

Thanks for the response, and yeah… I included a lot on StackOverflow. I only have the one object and I’m getting the current scale, changing the values on that object, then getting the scale immediately after again with no changes to the values. I would assume they should change, even if things are relative. I’ll take a look at that example and see if I can use their code for the scale slider in my code and see if it does anything. If you think of anything else, I’m happy to listen. Thanks!