Not seeing Model, Troubleshooting

The GLTF loader isn’t throwing any errors
When I try to render a mesh it works fine
I tried scaling and rotating the gltf scene but it doesn’t work

I’m out of ideas
Any other suggestions?

import * as three from "three";
import {GLTFLoader} from "three/addons/loaders/GLTFLoader.js";

const scene = new three.Scene();
const canvas = document.querySelector("#world");
const loader = new GLTFLoader();
const renderer = new three.WebGLRenderer({canvas});

const fov = 45;
const camera = new three.PerspectiveCamera(fov, 800/600);
camera.position.z = 20;

loader.load( './models/test.gltf', function ( gltf ) {
    gltf.scene.scale.set( 1000000,  1000000,  100000);
    scene.add( gltf.scene );

}, undefined, function ( error ) {

    console.error( error );

} );

const shape = new three.SphereGeometry(3, 64, 64);
const material = new three.MeshStandardMaterial({
    color: "#ff0304"

const body = new three.Mesh(shape, material);

const light = new three.PointLight(0xffffff, 1, 100);
light.position.set(0, 10, 10);

renderer.setSize(window.innerWidth*0.5, window.innerHeight*0.8);
const render = function () {
    renderer.render(scene, camera);

    requestAnimationFrame(() => render());

The code is all over the place, but I’m just trying to make it work

Do you mind sharing the glTF asset in this topic?

Sure, it’s just a quick model I made in Blockblench
test.gltf (21.0 KB)

The scaling is too big and non-uniform.
Why and what for? :thinking:

Not for any particular reason I just left it like that, I just tried different scaling factors

Ok, I hadn’t tried scaling it back to a normal size after adding the camera lookAt line. What a dumb mistake! Thank you