Glb file display texture Reflection abnormal

I meet a issue:
the glb is all the same to ply files,but when I display glb in three.js(,glb’ texture reflection is abnormal compared to ply displayed in cloudcompare.
here is the glb screenshot:

here is the ply screenshot:

here is the glb file:
youa_00039.glb (236.4 KB)

How this happen? How could I solve it ?I want glb displayed same to ply.

The GLB file looks the same in any glTF viewer (tested three.js, babylon.js, and Blender) so the file itself contains exactly what you are seeing.

The PLY is either not being converted correctly, or was made in a different way. I don’t think there’s any way to “fix” the broken GLB here, other than cropping out everything around the faces, so you may need to share details about how the file is created or file a bug with the tools used to do that.

well ,here is the glb files and ply files:

youa_00039_ori.glb and youa_00039.ply is the original files ,which contains the same xyz and texture coordinates \texture;
youa_00039.glb is simplied by meshoptimizer/gltf at master · zeux/meshoptimizer · GitHub
(you introduce this github tool to me for simply glb model by reduce face and vertex numbers )

I have check it once.And I have 2 issues:
issue one:I have a model both in ply and glb,and I display them in three.js and cloudcompare,but they looks not same,how could i get the the model(glb) show just same to ply?Any parameters should i set in three.js?

issue two:I just add a circle to my rgbd img to get a 3D model,but when I use meshoptimizer to simply the model ,meshoptimizer will simply anything in my model,in fact i only want to it simply the original 3D model except the circle I add.(perhaps i should put issue two in meshoptimizer’ github issue)
I find the difference by show the ori and simply model in wireframe only model

plus:the floor 1#,the ply is original model,but the glb is the simply 3D model,so it seems differently;

I guess I’m still not sure how you are turning this PLY file into these GLB files? The GLB files you’ve attached are broken, there is no easy way to fix them… they just don’t have the same data that is in the PLY file at all.

If you open the PLY in Blender and then export to glTF you’ll get a better result:

The PLY did not have any materials so I set it up like this in Blender:

And disabling the “normals” option at export may help to reduce file size since they aren’t needed here. Attached:

If you would like to simplify specific parts of the model that is really a 3D modeling task, I would recommend doing some tutorials in Blender (or another modeling tool) to get the hang of modifying geometry.