Glb comprssed by draco load failed in viewer based in three.js

when i get a glb files ,it is too big,so i use draco to compress it ,and get the compressed glb.
but when i load compressed glb in viewer ,here is the issue :

here is the compressed glb model:

Similar to the error you’re seeing, this file can’t be opened in any glTF tool I’ve tried. This may be an error in the MeshSmith conversion tool — can you share the original file, before Draco compression was added? If not, you may need to report a bug on the MeshSmith tool.

here you are,thanks for your attention:)

Can’t seem to access that link, sorry!

i have put it in google netdisk,thanks for your nice attention:)

It does look like there may be a problem in the MeshSmith tool; the compressed file is not valid. But trying to run this through a couple other Draco compression tools I’m getting WASM errors. Maybe that should be reported to the Draco team, or maybe it just relates to the RAM available to Node.js, which all of the tools I’m testing rely on.

In any case, Draco is probably not the right way to compress this model: it will make the file smaller, but will not make it render any faster. This model has 24M triangles, which is 3x more triangles than a 4K display has pixels, so it’s really way more detail is needed.

I’d recommend simplifying this model with the gltfpack tool instead:

gltfpack -i input.glb -o output.glb -si 0.05 -vp 16

The goal here is to reduce the number of vertices, rather than just compressing the existing vertices. This will bring your model’s size down a lot, and make it render faster. Blender’s “decimate” modifier is another way to do the same thing.

I think you are right!
MeshSmith tool use draco api instead so there is a problem in draco ,and I have post this issue in draco but still not get reply yet;

if i get reply and get issue resolved ,i will post here too;