Error while trying to load GLTF File

Hello, I am a beginner with three js and here I am for 2 days confronted with an error that I do not understand and that upsets me.

I’m just trying to import a gltf file into my canva three js.

I followed dozens of tutorials on youtube this weekend and everyone seems to use the same way. Which obviously doesn’t work for me.

This way is the one present on my screenshot.

I STILL get the error message on the screenshot.

All over the internet it seems that my error comes from a path problem but I tried everything, I tried to put it everywhere in my project but nothing worked.

I’m using parcel because the first tutorial I followed used it.

I installed three with npm.

I saw that there was a topic already existing with the name of my error but I can’t find any help there.

If any information is missing, I would add it with pleasure.

error.bmp (494.1 KB)

code.bmp (5.4 MB)

Hello @Loic_Carre
Nice to meet you in this forum.
I have read your post and I hope this will help you.
As well as you, I have tried to run three.js project loading 3D model with Parcel but I didn’t get good result.
It seemed the error of Parcel platform and I figured out that we could not run three.js project loading 3D model functionality. Please use the Xamp instead of Parcel to run it. Then, probably it will works well.
I think this is not important issue now.
I think we should go out and learn in wide scope.

Kind regards.

Ye parcel was messing it up, i re build it with vite.js and it worked perfectly fine, thanks !

Okay, I’m very happy to hear you work is going well.
I hope we will help each other in the future.
Thanks in advance.

Kind regards.