GLTF not appearing on mobile

I’m loading a GLTF into my scene normally, it’s working well when in a browser window, however when I go to the VRbrowser iphone app and bring up the localhost that my code is on, suddenly the GLTF file disappears. Everything else works fine, and has worked fine in the past as well, be that regular shapes, a star field (which is it’s own separate problem), and even textures called from the same folder this GLTF file is in. However, the GLTF simply doesn’t show up at all. Any reasons anyone can think of?

Do you have an example link?

It’s not going to work as i’m hosting my images/models on a localhost for the time being, but here’s the code i’m using:
Essentially it brings up a star field, a textured sphere, and a 3D model on browser, but only the stars and sphere on mobile.

Have you read this?

Yes i have, it’s what I’m using to host my code. This is what it shows when I run it:

However when I run it off my phone with the code still being locally hosted (connecting to the localhost through my IP), it looks the exact time minus the globe on the left.

Which app are you using to host a local server on your phone?

I’m using a python Localhost server on my computer. I connect my phone to the same WiFi as my computer, then navigate to it by the “IPV4 address :8000”. this takes me to the local server which i can pull my code through to view on my phone through the webvr app

I think for that to work, your code would have to reference the same ip. Localhost won’t work doing it that way.