Gltf model missing segments

I am loading a gltf model but for some reason, parts of it are not displayed is like it is glitchy, why is this happening?

How does it look in gltf-viewer? It looks like what typically happens when there’s no geometry bounding box or sphere… Maybe try this…


It looks the same, I mean the segments are still missing.

I tried computeBoundingSphere() with no luck… :frowning:

Looks like this entire mesh has alpha blending (.transparent = true) enabled, and probably shouldn’t. Maybe just alphaTest or alphaHash, if the textures have transparency.

1 Like

I got the model from , I tried others and all of them have this issue I tested it in the three viewer as well and the same issues appear so the issue is not with the viewer.

Is there anything that I van do inside the viewer code to fix this ?

If I set the mesh material transparent to false it fixes the issue… I don’t understand this things I am still a beginner…

Yes, I’d consider this a bug in the model itself. Often Sketchfab models are uploaded in one format, rendered on Sketchfab’s site using a proprietary format and engine, and then converted to glTF (or whatever you select) when you download them. Those conversions are sometimes lossy unfortunately, so I’d consider it normal to need to do some small fixes to models found online.

Thank you for letting me know.

I am a developer, and my 3D skills using Blender or something else are 0% :slight_smile: maybe at some point, I will learn at least the basics.

Setting the model mesh material transparent fixes this glitch, maybe this helps others.